Bersa Forum banner
1 - 4 of 4 Posts

· Registered
1 Posts
Discussion Starter · #1 · (Edited)
Hello, hoping someone had this problem and can assist. I have a Bersa FireStorm 380. Put maybe 50 rounds through it total and was running fine. Shot a little over one mag yesterday and still worked okay and then halfway into my next, just nothing. Thought I had a FTF. Tried again and same thing. Hammer will not drop. Trigger will go all the way back on DA, but hammer will not drop. On SA manually pulling the hammer back, won't drop and fire. It was just purchased late last year. The decocker works fine when I have the hammer back. Mag fully seats, safety and decocker works.

The disconnect bar looks straight and in place to me. The slide goes back on fine. When the safety is on, trigger is obviously real mushy/limp. When it is off and try to dry fire it, there is much more tension on the trigger like it should be and with the hammer moving as I squeeze, but then hammer does not drop. Yes, the mag is in since there is the mag disconnect feature. Never removed the grips before today, so nothing I could have done? Did a basic cleaning before I first shot it. Attached are some pics. Anything look out of place or assistance? Thanks!
1 - 4 of 4 Posts